GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

On May 23, 2025, between 17:40 UTC and 18:30 UTC public API and UI requests to read and write Git repository content were degraded and triggered user-facing 500 responses. On average, the error rate was 61% and peaked at 88% of requests to the service. This was due to the introduction of an uncaught fatal error in an internal service. A manual rollback was required which increased the time to remediate the incident.

We are working to automatically detect and revert a change based on alerting to reduce our time to detection and mitigation. In addition, we are adding relevant test coverage to prevent errors of this type getting to production.
Posted May 23, 2025 - 18:33 UTC

Update

API Requests is operating normally.
Posted May 23, 2025 - 18:33 UTC

Update

API Requests is experiencing degraded performance. We are continuing to investigate.
Posted May 23, 2025 - 18:26 UTC

Investigating

We are currently investigating this issue.
Posted May 23, 2025 - 18:21 UTC
This incident affected: API Requests.